Tuesday, 14 August 2007

Squeaky steering

Not been having much luck lately, a new noise appeared yesterday from the front of the car when turning the steering wheel. Didn't seem suspension related. An odd rubbery type sound...







I got it up on axle stands and the noise disappeared when the suspension wasn't under load. I dropped it back down and the noise had gone (!!).

I think it must have been something causing the rack gaitors to rub against the chassis (stone/road debris/etc).

Either that or the Elise got scared of me going at it with a spanner so has decided to fix itself ":-D"

On another note, I'm still waiting for the insurance assessor's report about the damage to the clam but it shouldn't be too long.

Wednesday, 8 August 2007

Another split clam...double bollocks.

Not having much luck lately - not long after someone went into the rear clam and someone hits the front one as well!

It happened a little while ago so its halfway sorted now, theres a new clam going on when the back gets done. It's also having a full respray so the car should look like new. Every cloud has a silver lining i suppose.

Anyway, the to-do list is growing....

- fit S2 suspension. Need to get the mounting bracket. Gonna DIY this.
- fresh geo
- buy and fit braided clutch hose and change fluid. Clutch is unusable when hot!
- fit CAT - maybe. Dont know if im gonna leave it on or just for MOT
- get some armourfend for the front once sprayed to stop stone chips

Insurance is also due in October so time to start saving for that as well! I got done speeding not so long ago (41 in a 30) so I've now got an SP30 on my license. Hope it doesn't hike my premium too much!

Red clutch hose is the bane of my life at the moment, its near impossible to change gear when the cars had a bit of a thrashing ":'("